[NL-AMS: Serverless functions/containers] Some domains are returning 404 errors
Incident Report for Scaleway
Resolved
All domains returning 404 errors this morning are now working again. Sorry about the inconvenience.
Posted Apr 11, 2024 - 15:18 CEST
Update
We are continuing to work on a fix for this issue.
Posted Apr 11, 2024 - 13:18 CEST
Update
This might also affect some domains in "ready" status, we are investigating.
Posted Apr 11, 2024 - 13:18 CEST
Identified
This affects users having domains configured long ago (> 2 months) with Cloudflare (or similar proxy system), and in "error" status.

Despite the domains in "error" status, these still continued to serve traffic correctly. But, due to a change in our infrastructure, these domains are now unreachable (returning 404 errors). Users with domains in "error" status have to recreate their custom domain.

Note that the function/containers under the custom domain are still reachable through their default endpoint: only the custom domain is returning 404 errors.
Posted Apr 11, 2024 - 11:42 CEST
This incident affected: Elements - Products (Functions and Containers).