Wednesday 24th April 2019

Billing API [SCW] API Payment down

Our API payment system for Scaleway was down for a few hours.
During this downtime, you could not add a credit card nor pay your unpaid invoice.
If you tried during this time and encountered an error, we invite you to retry.

===================

04.25.2019 0030Z (0130LT)

Issue is back, you can have difficulty to add a new credit card or pay a bill. Issue won't be solved before tomorrow.

04.24.2019 2032Z (2132LT)

The issue has been fixed by our billing team. Everything is back to normal.

04.24.2019 1832Z (1932LT)

Issue has been escalated to local team