Wednesday 24th July 2019

Mail Web hosting modifications issue

Several actions on web hosting are not possible due to an internal issue.

For example PHP version modification, mail creation, password mail update.

We apologize for the inconvenience.

Thank you for your patience.

Next update by 07.23.19 1115Z (1315LT)

===================

07.23.19 0900Z (1100LT)

Issue has been escalated to local team

UPDATE: Actions are now fixed. Only remains some actions on mailboxes that are stuck. We are still working on fixing this.