Wednesday 2nd October 2019

Console [CONSOLE] Billing page unavailability

We have detected an issue with Scaleway console billing page.

Downloading invoice, new credit card adding may return an error on your console.

Our engineers are working on fixing this as soon as possible.

===================

2019-10-04 1030Z (1230LT)

Issue has fixed earlier yesterday and everything seems to be stable again.
Should you still face issues on your end, please contact our support team by ticket.

2019-10-02 1530Z (1730LT)

Issue has been escalated to local team