Friday 4th October 2019

Dedibackup [Dedibackup] Delivery issues

We have noticed issues with the Dedibackup platform, and new Dedibackup FTP spaces are currently not being delivered.

===================

10.04.19 1606Z (1806LT)

Issue with Dedibackup has been fixed

10.04.19 1345Z (1545LT)

Issue has been escalated to local team