Tuesday 26th May 2020

Mail [Webhosting] Mail issue in our webhosting plateform

We have detected an issue in our webhosting plateform, any modification to an email account will fail until further notice
The dedicated team is currently working on it.

===================

27/05/202 0800Z (1000LT)

Issue has been fixed

26/05/202 1015Z (1215LT)

The product team has identified the root cause and working on a fix

26.05.2020 1000Z (1200LT)

Issue has been escalated to local team