Tuesday 30th June 2020

Mail [Web hosting] SMTP

We are currently encountering an issue regarding our SMTP servers. Your email may not be delivered properly. Our webhosting team is investigating the situation. Next update once we have more information

===================

07.01.20 0730Z (0930LT)

Issue has now been fixed, SMTP servers are now answering to webmail requests correctly.

06.30.20 1930Z (2130LT)

Issue has been escalated to local team