Thursday 2nd July 2020

Mail [Web Hosting] Webmail access error

We are currently facing an issue with webmail access.

Webmail login attempts return to 504 error.

===================

07.02.2020 1610Z (1810LT)

Issue has been fixed, webmail is now available

07.02.2020 1545Z (1745LT)

Issue has been escalated to local team