Thursday 23rd July 2020

Mail [WEB HOSTING] Webmail login issues

We are currently facing an issue with our webmail platform.

Login process isn't finished, and get a 504 error.

===================

2020-07-23 1300Z (1400LT)

Issue has been fixed, all email platforms are now reachable again.

2020-07-23 1300Z (1400LT)

We are still noticing stability issues, it has been escalated back to our Hosting team.
We will update this status as soon as we have additional details.

2020-07-23 1300Z (1400LT)

Our product team solved the issue

2020-07-23 1200Z (1300LT)

Issue has been escalated to local team