Saturday 1st August 2020

Dedibackup [Dedibackup] Connection issues

Some of our Dedibackup servers are unavailable at the moment, you may experience issues when trying to connect to your backup FTP space.

===================

08.03.20 1210Z (1410LT)

Issue has been solved by our product team.

08.01.20 1100Z (1300LT)

Issue has been escalated to local team.