Tuesday 8th September 2020

[WEBHOSTING] Issue with some mails account

We are currently encountering an issue with some mails account, causing the email address unavailable.
The dedicated team has been informed and working on it.
If you have any issue accessing to your email address, please contact the support.

===================

09.10.2020 0955Z (1155LT)

issue has been fixed

09.08.2020 1230Z (1430LT)

Issue has been escalated to local team