Status impact color legend
  • Black impact: None
  • Yellow impact: Minor
  • Orange impact: Major
  • Blue impact: Maintenance
[OBJECT-STORAGE] CORSPreflightRequest on Bucket issue
Incident Report for Scaleway
Resolved
The fix has been deployed everywhere.
Posted Jan 31, 2025 - 15:06 CET
Identified
We are currently rolling out the fix, everything should be back to normal by the end of this morning.
Posted Jan 31, 2025 - 11:06 CET
Investigating
After upgrading our S3 gateway, we encountered a problem on buckets with CORSConfiguration with a value of "*" in their AllowedHeaders.

In this particular case, the CORS preflight request does not return the `Access-Control-Allow-Headers' header and fails the validation.

If you have a CORS configuration on your bucket with the value AllowedHeaders: *, the CORS preflight request will fail for all headers.

We plan to roll out the fix tomorrow and deeply apologize for the inconvenience.
Posted Jan 30, 2025 - 16:52 CET
This incident affected: Elements - Products (Object Storage).