[Serverless functions/containers] Retry policy for SQS triggers is not working, and messages are replayed infinitely
Incident Report for Scaleway
Resolved
This incident has been resolved.
Posted Apr 11, 2024 - 10:29 CEST
Identified
In normal cases, if a SQS message can't be processed by a SQS trigger because the underlying function/container returns a non-OK status code (4xx, 5xx), our system will retry 3 times before dropping the message. Today, this retry mechanism is broken due to incompatibilities with the SQS protocol, so messages will be replayed infinitely if the function/container return a non-OK status code.

As a workaround, users can always return a 200 status code in their function/container, even if the processing of the message returns an applicative error. This is just a workaround though, as we have identified the root cause, and a fix is coming.

Sorry about the inconvenience.
Posted Apr 03, 2024 - 16:48 CEST
This incident affected: Elements - Products (Functions and Containers).