[K8S] Kapsule clusters with public-only endpoints are End of Life
Scheduled for Apr 1, 09:00 - 12:00 CEST
Update
Update: Scheduled for April 1, 2024
Posted Feb 28, 2024 - 11:01 CET
Scheduled
In order to future-proof your infrastructure and harden security, legacy public-only Kapsule clusters (i.e without any private endpoint) will be End of Life as of 18 March 2024.

Ending the deprecation cycle, Kapsule clusters still with public-only endpoints will be migrated to Private Networks over the following weeks. The migrations will happen region per region, in this order:
1. PL-WAW
2. NL-AMS
3. FR-PAR

With the new default isolation configuration offered by Kapsule, your worker nodes will keep their public IPs to access the Internet. After migrating, past security groups configuration won’t be overridden and RR wildcard DNS still point to public IPs.

Warning: during the migration, all pods of the CNI are restarted. The pod network of your cluster will thus be temporarily unavailable for 1 to 10 minutes (depending on the size of your cluster and the CNI you are using).

Find our dedicated documentation on Kapsule with Private Networks https://www.scaleway.com/en/docs/containers/kubernetes/reference-content/secure-cluster-with-private-network/#how-can-i-migrate-my-existing-clusters-to-regional-private-networks
Posted Dec 01, 2023 - 10:08 CET
This scheduled maintenance affects: Elements - Products (Kapsule).