[Elements] Payment cards addition issues
Incident Report for Scaleway
Resolved
This incident has been resolved.
Posted Oct 07, 2021 - 11:21 CEST
Investigating
We are encountering issues with the addition of payment cards to Scaleway Elements accounts.
It is currently not possible to add a new card to your account.
Posted Oct 07, 2021 - 10:49 CEST
This incident affected: Elements - Products (Billing API).