Status impact color legend
  • Black impact: None
  • Yellow impact: Minor
  • Red impact: Major
  • Blue impact: Maintenance

[BLOCK STORAGE] - [fr-par-1] - Increase of API latency

Incident Report for Scaleway

Resolved

Starting at 18h00 UTC block storage API response times increased until it became really significant at 19h02~ UTC.

This impacted the API with slow response times. Some calls have failed (Internal error) due to the database load.
No impact on Data plane (block volumes) performances.

Our team found a SQL optimization issue linked to the call ListVolumes and fixed it at 21h44 UTC.
Since then, response times came back to normal and error rate dropped as well.
Posted Apr 15, 2025 - 01:29 CEST

Investigating

We are spotting an increase of API latency on the Block storage API with a degradation of the P99 latencies on some API methods.
Posted Apr 14, 2025 - 22:13 CEST
This incident affected: Elements - Products (Block Storage).