[Support] Difficult to reach phone support
Incident Report for Scaleway
Resolved
The phone support is now back and working.
You can contact us again by phone if needed.

The Scaleway team thanks you for your cooperation and patience!
Posted Nov 16, 2022 - 15:20 CET
Investigating
Due to a problem with our phone system, it is currently difficult to contact us by phone, you can reach us by tickets and live chat support if needed.
We are currently investigating the situation and will update this status as soon as we have more information.
Posted Nov 16, 2022 - 14:25 CET
This incident affected: Miscellaneous (Excellence).