We have completed the cluster upgrades from 1.27 to 1.28 and from 1.28 to 1.29. The upgrades from 1.29 to 1.30 remain scheduled for the previously indicated dates. You can always upgrade yourself in advance if you want to choose the upgrade date and time.
Posted Apr 25, 2025 - 10:14 CEST
Update
Here the base date for the update per region :
1.27 WAW : April 8th AMS : April 9th PAR : April 10th
1.28 WAW : April 21st AMS : April 22nd PAR : April 23rd
1.29 WAW : May 14th AMS : May 19th PAR : May 21st
Please be aware that all clusters will be done progressively. Your cluster maintenance may not occur on the said date.
Posted Apr 07, 2025 - 17:26 CEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 07, 2025 - 08:00 CEST
Scheduled
On April 7 2025, Kubernetes versions 1.27, 1.28, and 1.29 will reach their end-of-support date.
Clusters still running these versions will automatically be upgraded to Kubernetes 1.30 within 30 days to ensure continued security and performance.
No immediate action is required, but we recommend reviewing our upgrade documentation for best practices.