[Account] KYC Verification issue
Incident Report for Scaleway
Resolved
This incident has been resolved.
Posted Oct 13, 2021 - 11:40 CEST
Investigating
We are currently encountering an issue with our KYC system. The verification may not go through.
If the verification is stuck, please create a ticket.
Posted Oct 11, 2021 - 14:03 CEST
This incident affected: Elements - Products (Elements Console).