Kapsule clusters unstable in fr-par
Incident Report for Scaleway
Resolved
We re-enabled the cluster upgrade and configuration update features. The incident is now resolved. We will share a detailed incident report on the Scaleway Blog in the coming days.
We apologise for the inconvenience that this incident might have caused, and we thank you for your understanding.
Posted Feb 20, 2024 - 16:48 CET
Identified
We are taking additional corrective actions to prevent incident occurrence. Once completed, we will re-enable the cluster upgrade and configuration update features
Posted Feb 19, 2024 - 14:30 CET
Update
The outage on Kubernetes clusters in the FR Paris region is stabilized.
Corrective actions taken: more CPU and memory for the Kubernetes API, modifications to prevent blast radius
Ongoing actions: infrastructure changes and implementation of new internal modules.
Posted Feb 15, 2024 - 18:29 CET
Update
All clusters upgrade and update will be disabled as long post-mortem and fixes are not written. We are still monitoring the service
Posted Feb 13, 2024 - 17:20 CET
Investigating
A new degradation has been observed :
Our public API gateway is under heavy load on fr-par and experiences slowness.
K8s APIs are more impacted with frequents downtimes.
Some other products APIs have some short periods of unavailability.
Serverless functions/container, and Cockpit are also affected.

We are currently working on fixes.
Posted Feb 13, 2024 - 16:18 CET
This incident affected: Elements - AZ (fr-par-1, fr-par-2, fr-par-3).