Status impact color legend
  • Black impact: None
  • Yellow impact: Minor
  • Red impact: Major
  • Blue impact: Maintenance

[BILLING] DDX2ELT clients SEPA payment failures

Incident Report for Scaleway

Resolved

A fix has been deployed to prevent this from happening again for future billings.

SEPA direct debit has been relaunched for customers whose CB payment failed.

However, for CB payments that worked, there will be no refund on the CB and no direct debit launched on SEPA.

We apologize for any inconvenience caused.
Posted Jun 06, 2025 - 08:41 CEST

Identified

On June 2nd, a bug in our Payment API caused SEPA payment failures for some DDX2LT clients.

As a fallback, the system tried to charge by credit card, but some of those payments also failed.

We have identified the issue and are working on a fix.
Once resolved, we will provide appropriate solutions for affected clients.
Posted Jun 04, 2025 - 15:20 CEST
This incident affected: Elements - Products (Billing API).