[Elements] Card payment issues
Incident Report for Scaleway
Resolved
A fix has been deployed , all payments affected will be retried tommorrow.
If you still encounter some errors, please contact the support team
Posted Aug 03, 2022 - 18:00 CEST
Identified
The issue has been identified and we are currently trying to deploy a general fix for all impacted customers
Posted Aug 03, 2022 - 16:27 CEST
Investigating
We are investigating an abnormal amount of failed payments, this appears to be an issue on our end.

Our billing team has been notified, we will update this status as soon as we have more information.
Posted Aug 03, 2022 - 14:26 CEST
This incident affected: Elements - Products (Billing API).