[WEBHOSTING]-Some mailboxes are inaccessible
Incident Report for Scaleway
Resolved
This incident has been resolved.
Posted May 08, 2024 - 13:51 CEST
Investigating
Some mailboxes are inaccessible on several different PF

"Filer" seems to be affected

Our engineers are investigating the situation
Posted May 08, 2024 - 10:23 CEST
This incident affected: Dedibox - Products (Hosting).