Status impact color legend
  • Black impact: None
  • Yellow impact: Minor
  • Red impact: Major
  • Blue impact: Maintenance

[Serverless Containers] - [world] - Scaling issues on private network

Incident Report for Scaleway

Update

Unlike said in the initial message, note that this race condition, despite rare, can be triggered for functions and containers on all regions.
We have also seen rare occurrences of this bug in the previous weeks.
Posted Nov 18, 2025 - 11:50 CET

Identified

The root cause has been identified. Due to a race condition in the private network management, it can occasionally happen that some functions/containers instances are not able to start.

This race condition stays rare, and we are working on a fix. In the meantime, in case a function/container attached to a PN cannot scale up, deploying again the function/container can solve the issue.

Sorry for any inconvenience.
Posted Nov 18, 2025 - 11:39 CET

Investigating

Since 2025/11/14, some Serverless Functions and Containers attached to a private network in the fr-par region may experience scaling issues.
This can result in request timeouts for functions/containers scaling from zero, or failure to scale up for those with a minimum scale of 1. We are currently investigating this issue, which only affects functions/containers attached to a private network.
Posted Nov 18, 2025 - 09:58 CET
This incident affects: Elements - AZ (fr-par-1, fr-par-2, fr-par-3) and Elements - Products (Serverless Functions and Containers).