[BILLING] Purchase orders fail
Incident Report for Scaleway
Resolved
This incident has been resolved.
Posted Jan 31, 2023 - 17:26 CET
Update
We are continuing to investigate this issue.
Posted Jan 31, 2023 - 15:45 CET
Investigating
Customer are unable to order Monthly Elastic Metal and domains.
We are investigating the issue and will update this page accordingly.
Posted Jan 31, 2023 - 15:27 CET
This incident affected: Elements - Products (Domains, Billing API, Elastic Metal).