Status impact color legend
  • Black impact: None
  • Yellow impact: Minor
  • Red impact: Major
  • Blue impact: Maintenance

[SERVERLESS CONTAINER/FUNCTION][NL-AMS] - Sporadic 502 and 504 errors

Incident Report for Scaleway

Monitoring

From what we have seen as of now, it seems that the time ranges on which users receive 5xx errors match with a higher load and more connections opened on our gateways.

We have deployed a fix to increase the capacity of our gateways on 8:45 UTC, and we are closely monitoring the situation.

We sincerely apologize for any inconvenience.
Posted Jan 23, 2026 - 13:35 CET

Update

Erratum:
- So far, the first occurrences of this issue appeared on 2026-01-08. We are still gathering metrics to understand if it has also happened before.
- Impacted users might see all of their requests during specific periods of time (from 10m to 30m) return 5xx errors.
Posted Jan 23, 2026 - 13:35 CET

Investigating

A subset of users on nl-ams (~35%) may experience sporadic 502 or 504 errors when accessing their Serverless Functions and Serverless Containers. These errors are very sporadic, so we expect only a few amount of requests to fail.

We've seen the first occurrences on 2026-01-20.
We are investigating, sorry about any inconvenience.
Posted Jan 23, 2026 - 11:48 CET
This incident affects: Elements - AZ (nl-ams-1, nl-ams-2, nl-ams-3) and Elements - Products (Serverless Functions and Containers).