Status impact color legend
  • Black impact: None
  • Yellow impact: Minor
  • Red impact: Major
  • Blue impact: Maintenance

[Domain] Temporary interruption of Domain Services

Scheduled for May 12, 10:00 - 18:00 CEST

Update

We will be undergoing scheduled maintenance during this time.
Posted May 02, 2025 - 16:55 CEST

Scheduled

This operation will result in the temporary unavailability of certain domain-related features.

This upgrade is a key step in modernizing our Domain infrastructure to ensure greater stability, performance, and long-term scalability.

What will be temporarily unavailable during the maintenance:
Domain name purchases and orders
Domains API
What remains fully operational:
DNS resolution
DNS modifications (zone updates, new records, etc.)
Posted May 02, 2025 - 16:13 CEST
This scheduled maintenance affects: Dedibox - Products (Domains) and Elements - Products (Domains).