[Elements] Identity verification issue
Incident Report for Scaleway
Resolved
The issue has been fixed, the identity verification process is now working as expected.
Posted May 04, 2022 - 11:41 CEST
Identified
We have noticed an issue with our identity verification process, which cannot be resumed or retried if interrupted.
The root cause has been identified and will be fixed as soon as possible, we will update this status accordingly.
Posted May 03, 2022 - 18:33 CEST
This incident affected: Elements - Products (Elements Console).