[WEBHOSTING] SMTP blacklisted on Microsoft/Outlook from classic webhosting service
Incident Report for Scaleway
Resolved
This incident has been resolved.
Posted Dec 08, 2022 - 14:25 CET
Investigating
Our teams are currently working on delisting our smtp server on Microsoft for services related to webhosting classic

Thank you in advance for your patience and cooperation
Posted Nov 18, 2022 - 17:45 CET
This incident affected: Dedibox - Products (Hosting).