Status impact color legend
  • Black impact: None
  • Yellow impact: Minor
  • Red impact: Major
  • Blue impact: Maintenance

[PAYMENT] - [All] - issue with AMEX card payment

Incident Report for Scaleway

Resolved

This incident has been resolved.
Posted Jun 05, 2026 - 16:21 CEST

Monitoring

The incident is now mitigated, and we are actively monitoring the situation.

Failed AMEX payments have been retried and are processing successfully.

New orders and renewals can now be processed using AMEX as normal.
Posted Jun 05, 2026 - 14:24 CEST

Identified

We have identified the issue and are currently working on a fix.
Posted Jun 04, 2026 - 12:03 CEST

Investigating

We have noticed that payments with AMEX card are not successful.
Our engineers are investigating.
Posted Jun 02, 2026 - 10:57 CEST
This incident affected: Dedibox - Products (Dedibox) and Elements - Products (Billing).