Status impact color legend
  • Black impact: None
  • Yellow impact: Minor
  • Red impact: Major
  • Blue impact: Maintenance

[Serverless Functions] - [fr-par/nl-ams/pl-waw] DNS resolution failures for all functions

Incident Report for Scaleway

Resolved

The root cause has been fixed: all functions now have a working DNS again. The incident is now closed.

Impacted functions were:

- on fr-par, only functions not attached to a private network, that belong to a namespace created after 2026-04-28 8:00 AM UTC, until 1:05 PM UTC.
- on nl-ams, all functions not attached to a private network, between 8:41 AM UTC and 1:46 PM UTC
- on pl-waw, all functions not attached to a private network, between 9:30 AM UTC and 1:05 PM UTC

The incident on nl-ams and pl-waw is related to the scheduled maintenance https://status.scaleway.com/incidents/zrhfpqjvjyrl. A mismatch between DNS service IPs caused the issue.

We deeply apologize for the inconvenience.
Posted Apr 28, 2026 - 15:50 CEST

Update

After investigation, this also affects functions created on new namespaces on fr-par.
Posted Apr 28, 2026 - 14:16 CEST

Update

We are continuing to investigate this issue.
Posted Apr 28, 2026 - 14:11 CEST

Investigating

Customers may experience DNS resolution failures for their Serverless Functions in the nl-ams and pl-waw regions, due to an error that happened during the scheduled maintenance: https://status.scaleway.com/incidents/qhh06fhhn47r.

Errors for clients might look like: "lookup [...] on 10.32.15.25:53: read udp 100.96.xx.xx:xx->10.32.15.25:53: i/o timeout".

We have identified the root cause. Sorry about any inconvenience.
Posted Apr 28, 2026 - 14:06 CEST
This incident affected: Elements - AZ (fr-par-1, fr-par-2, fr-par-3, nl-ams-1, nl-ams-2, nl-ams-3, pl-waw-1, pl-waw-2, pl-waw-3) and Elements - Products (Serverless Functions).